DHCP给不同vlan分配IP

2023年6月26日14:41:03 评论 189
首月免费体验
<Huawei>system-view 
[Huawei]undo info-center enable 
[Huawei]sysname AR1
[AR1]dhcp enable

VLAN 10配置DHCP:
[AR1]interface GigabitEthernet 0/0/0.10    #创建子接口
[AR1-GigabitEthernet0/0/0.10]ip address 10.10.10.1 24    #配置IP地址
[AR1-GigabitEthernet0/0/0.10]dot1q termination vid 10    #绑定vlan10
[AR1-GigabitEthernet0/0/0.10]arp broadcast enable    #开启arp广播
[AR1-GigabitEthernet0/0/0.10]dhcp select global    #全局分配地址
[AR1-GigabitEthernet0/0/0.10]quit       #退出

[AR1]ip pool vlan10        #创建地址池vlan10
[AR1-ip-pool-vlan10]network 10.10.10.0 mask 24        #设定网段
[AR1-ip-pool-vlan10]gateway-list 10.10.10.1        #配置网关地址
[AR1-ip-pool-vlan10]dns-list 10.10.10.1        #配置dns地址
[AR1-ip-pool-vlan10]quit



VLAN 20配置DHCP:
[AR1]interface GigabitEthernet 0/0/0.20
[AR1-GigabitEthernet0/0/0.20]ip address 20.20.20.1 24
[AR1-GigabitEthernet0/0/0.20]dot1q termination vid 20
[AR1-GigabitEthernet0/0/0.20]arp broadcast enable
[AR1-GigabitEthernet0/0/0.20]dhcp select global
[AR1-GigabitEthernet0/0/0.20]quit 

[AR1]ip pool vlan20
[AR1-ip-pool-vlan20]network 20.20.20.0 mask 24
[AR1-ip-pool-vlan20]gateway-list 20.20.20.1
[AR1-ip-pool-vlan20]dns-list 20.20.20.1
[AR1-ip-pool-vlan20]quit 



VLAN 30配置DHCP:
[AR1]interface GigabitEthernet 0/0/0.30
[AR1-GigabitEthernet0/0/0.30]ip address 30.30.30.1 24
[AR1-GigabitEthernet0/0/0.30]dot1q termination vid 30
[AR1-GigabitEthernet0/0/0.30]arp broadcast enable
[AR1-GigabitEthernet0/0/0.30]dhcp select global
[AR1-GigabitEthernet0/0/0.30]quit

[AR1]ip pool vlan30
[AR1-ip-pool-vlan30]network 30.30.30.0 mask 24
[AR1-ip-pool-vlan30]gateway-list 30.30.30.1
[AR1-ip-pool-vlan30]dns-list 30.30.30.1



VLAN 80配置DHCP:
[AR1]interface GigabitEthernet 0/0/0.80
[AR1-GigabitEthernet0/0/0.80]ip address 80.80.80.1 24
[AR1-GigabitEthernet0/0/0.80]dot1q termination vid 80
[AR1-GigabitEthernet0/0/0.80]arp broadcast enable
[AR1-GigabitEthernet0/0/0.80]dhcp select global
[AR1-GigabitEthernet0/0/0.80]quit

[AR1]ip pool vlan80
[AR1-ip-pool-vlan80]network 80.80.80.0 mask 24
[AR1-ip-pool-vlan80]gateway-list 80.80.80.1
[AR1-ip-pool-vlan80]dns-list 80.80.80.1



VLAN 90配置DHCP:
[AR1]interface GigabitEthernet 0/0/0.90
[AR1-GigabitEthernet0/0/0.90]ip address 90.90.90.1 24
[AR1-GigabitEthernet0/0/0.90]dot1q termination vid 90
[AR1-GigabitEthernet0/0/0.90]arp broadcast enable
[AR1-GigabitEthernet0/0/0.90]dhcp select global 
[AR1-GigabitEthernet0/0/0.90]quit

[AR1]ip pool vlan90
[AR1-ip-pool-vlan90]network 90.90.90.0 mask 24
[AR1-ip-pool-vlan90]gateway-list 90.90.90.1
[AR1-ip-pool-vlan90]dns-list 90.90.90.1
weinxin
博主微信
这是我的微信扫一扫

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: